Skip to main content

🚨 Severe Thunderstorm Warning — South Charleston WV

major icon Major
South Charleston Weather Conditions icon
South Charleston Weather Conditions
Investigating icon Investigating

Incident timeline

major icon Major

Investigating - ⚠️ Severe Thunderstorm Warning issued June 18 at 7:54AM EDT until June 18 at 8:30AM EDT by NWS Charleston WV
Severity: Severe | Urgency: Immediate
Issued by: NWS Charleston WV
Effective: 2026-06-18T07:54:00-04:00
Expires: 2026-06-18T08:30:00-04:00
SVRRLX The National Weather Service in Charleston West Virginia has issued a * Severe Thunderstorm Warning for...
Central Buchanan County in southwestern Virginia...
McDowell County in southern West Virginia...
Mingo County in southern West Virginia...
South central Kanawha County in central West Virginia...
Raleigh County in southeastern West Virginia...
Wyoming County in southern West Virginia...
Logan County in southern West Virginia...
Southern Fayette County in southeastern West Virginia....
Instructions: Remain alert for a possible tornado! Tornadoes can develop quickly
from severe thunderstorms. If you spot a tornado go at once into the
basement or small central room in a sturdy structure.
For your protection move to an interior room on the lowest floor of a
building.
Torrential rainfall is occur...

Affected:
South Charleston Weather Conditions icon
South Charleston Weather Conditions