Skip to main content

🚨 Severe Thunderstorm Warning — Barboursville WV

major icon Major
Barboursville Weather Conditions icon
Barboursville Weather Conditions
Investigating icon Investigating

Incident timeline

major icon Major

Investigating - ⚠️ Severe Thunderstorm Warning issued June 18 at 6:19AM EDT until June 18 at 6:45AM EDT by NWS Charleston WV
Severity: Severe | Urgency: Immediate
Issued by: NWS Charleston WV
Effective: 2026-06-18T06:19:00-04:00
Expires: 2026-06-18T06:45:00-04:00
SVRRLX The National Weather Service in Charleston West Virginia has issued a * Severe Thunderstorm Warning for...
Southeastern Lawrence County in northeastern Kentucky...
Southwestern Mason County in western West Virginia...
Eastern Cabell County in central West Virginia...
Northwestern Mingo County in southern West Virginia...
Kanawha County in central West Virginia...
Putnam County in western West Virginia...
Lincoln County in central West Virginia...
Southwestern Roane County in central Wes...
Instructions: Remain alert for a possible tornado! Tornadoes can develop quickly
from severe thunderstorms. If you spot a tornado go at once into the
basement or small central room in a sturdy structure.
For your protection move to an interior room on the lowest floor of a
building.
Torrential rainfall is occur...

Affected:
Barboursville Weather Conditions icon
Barboursville Weather Conditions