Skip to main content

⛈️ Flood Watch — South Charleston WV

minor icon Minor
South Charleston Weather Conditions icon
South Charleston Weather Conditions
Investigating icon Investigating

Incident timeline

minor icon Minor

Investigating - ⚠️ Flood Watch issued May 25 at 1:37AM EDT until May 25 at 2:00AM EDT by NWS Charleston WV
Severity: Severe | Urgency: Future
Issued by: NWS Charleston WV
Effective: 2026-05-25T01:37:00-04:00
Expires: 2026-05-25T09:45:00-04:00
The Flood Watch will expire for portions of southwest Virginia,
including the following counties, Buchanan and Dickenson and West
Virginia, including the following counties, Boone, Braxton, Clay,
Harrison, Kanawha, Lewis, Logan, McDowell, Mingo, Northwest Fayette,
Northwest Nicholas, Northwest Raleigh, Northwest Webster, Southeast
Fayette, Southeast Nicholas, Southeast Raleigh, Southeast Webster,
Upshur and Wyoming.
The flash flooding threat has ended for this morning. Therefore, the
Flood Watc...
Instructions: You should monitor later forecasts and be prepared to take action
should Flash Flood Warnings be issued.
Additional information can be found at https://www.weather.gov/rlx as
well as on our X and Facebook pages.

Affected:
South Charleston Weather Conditions icon
South Charleston Weather Conditions