Snap on EPC

Incident Report for System Status

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 18:59 EDT

Monitoring

Snap on EPC is currently experiencing issues. They can not provide a resolution time.
Posted Jul 11, 2025 - 14:39 EDT
This incident affected: 1682 - Barboursville Kia, 1796 - Charleston CDJR/KIA, and 1797 - Charlotte Kia.