Skip to main content

🚨 Severe Thunderstorm Warning — South Charleston WV

major icon Major
South Charleston Weather Conditions icon
South Charleston Weather Conditions
Investigating icon Investigating

Incident timeline

major icon Major

Investigating - ⚠️ Severe Thunderstorm Warning issued June 12 at 1:57PM EDT until June 12 at 2:30PM EDT by NWS Charleston WV
Severity: Severe | Urgency: Immediate
Issued by: NWS Charleston WV
Effective: 2026-06-12T13:57:00-04:00
Expires: 2026-06-12T14:30:00-04:00
SVRRLX The National Weather Service in Charleston West Virginia has issued a * Severe Thunderstorm Warning for...
Central Kanawha County in central West Virginia...
East central Lincoln County in central West Virginia...
Northern Boone County in central West Virginia...
* Until 230 PM EDT. * At 157 PM EDT, a severe thunderstorm was located near Alum Creek,
or 11 miles north of Madison, moving east at 30 mph.
HAZARD...60 mph wind gusts and quarter size hail. SOURCE...Radar indicated. IMPAC... Instructions: For your protection move to an interior room on the lowest floor of a
building.

Affected:
South Charleston Weather Conditions icon
South Charleston Weather Conditions