Skip to main content

🚨 Severe Thunderstorm Warning — South Charleston WV

major icon Major
South Charleston Weather Conditions icon
South Charleston Weather Conditions
Investigating icon Investigating

Incident timeline

major icon Major

Investigating - ⚠️ Severe Thunderstorm Warning issued June 14 at 7:50PM EDT until June 14 at 8:00PM EDT by NWS Charleston WV
Severity: Severe | Urgency: Immediate
Issued by: NWS Charleston WV
Effective: 2026-06-14T19:50:00-04:00
Expires: 2026-06-14T20:00:00-04:00
The storm which prompted the warning has weakened below severe
limits, and no longer poses an immediate threat to life or property.
Therefore, the warning will be allowed to expire. However, gusty
winds are still possible with this thunderstorm.
A Severe Thunderstorm Watch remains in effect until 900 PM EDT for
central West Virginia.

Affected:
South Charleston Weather Conditions icon
South Charleston Weather Conditions