Skip to main content

⛈️ Flood Watch — Bristol TN

minor icon Minor
Bristol Weather Conditions icon
Bristol Weather Conditions
Investigating icon Investigating

Incident timeline

minor icon Minor

Investigating - ⚠️ Flood Watch issued June 7 at 2:09PM EDT until June 8 at 9:00PM EDT by NWS Morristown TN
Severity: Severe | Urgency: Future
Issued by: NWS Morristown TN
Effective: 2026-06-07T14:09:00-04:00
Expires: 2026-06-08T03:00:00-04:00
* WHAT...Flash flooding caused by excessive rainfall is possible. * WHERE...A portion of east Tennessee, including the following
areas, Claiborne, Cocke Smoky Mountains, Grainger, Hamblen,
Hancock, Hawkins, Jefferson, Johnson, Northwest Carter, Northwest
Cocke, Northwest Greene, Southeast Carter, Southeast Greene,
Sullivan, Unicoi and Washington TN.
* WHEN...From Monday afternoon through Monday evening. * IMPACTS...Excessive runoff may result in flooding of rivers,
creeks, streams, and other ...
Instructions: You should monitor later forecasts and be prepared to take action
should Flash Flood Warnings be issued.

Affected:
Bristol Weather Conditions icon
Bristol Weather Conditions