Skip to main content

🚨 Flash Flood Warning — Huntington WV

major icon Major
Huntington Weather Conditions icon
Huntington Weather Conditions
Investigating icon Investigating

Incident timeline

major icon Major

Investigating - ⚠️ Flash Flood Warning issued May 24 at 6:11PM EDT until May 24 at 10:15PM EDT by NWS Charleston WV
Severity: Severe | Urgency: Immediate
Issued by: NWS Charleston WV
Effective: 2026-05-24T18:11:00-04:00
Expires: 2026-05-24T22:15:00-04:00
FFWRLX The National Weather Service in Charleston has issued a * Flash Flood Warning for...
Eastern Gallia County in southeastern Ohio...
East Central Lawrence County in southeastern Ohio...
North Central Cabell County in central West Virginia...
Northwestern Mason County in western West Virginia...
* Until 1015 PM EDT. * At 611 PM EDT, Doppler radar indicated thunderstorms producing
heavy rain across the warned area. Flash flooding is ongoing or
expected to begin shortly.
HAZARD...Flash fl... Instructions: Turn around, don't drown when encountering flooded roads. Most flood
deaths occur in vehicles.
Be aware of your surroundings and do not drive on flooded roads. Report flooding to the National Weather Service by calling toll free,
800 401 9535, when you can do so safely.

Affected:
Huntington Weather Conditions icon
Huntington Weather Conditions