Skip to main content

⛈️ Flood Watch — Bristol TN

minor icon Minor
Bristol Weather Conditions icon
Bristol Weather Conditions
Investigating icon Investigating

Incident timeline

minor icon Minor

Investigating - ⚠️ Flood Watch issued June 27 at 9:44AM EDT until June 28 at 11:00AM EDT by NWS Morristown TN
Severity: Severe | Urgency: Future
Issued by: NWS Morristown TN
Effective: 2026-06-27T09:44:00-04:00
Expires: 2026-06-28T00:00:00-04:00
* WHAT...Flooding caused by excessive rainfall is possible. * WHERE...Portions of east Tennessee, including the following areas,
Anderson, Bledsoe, Blount Smoky Mountains, Campbell, Claiborne,
Cocke Smoky Mountains, Grainger, Hamblen, Hancock, Hawkins,
Jefferson, Johnson, Knox, Loudon, McMinn, Meigs, Morgan, North
Sevier, Northwest Blount, Northwest Carter, Northwest Cocke,
Northwest Greene, Northwest Monroe, Rhea, Roane, Scott TN, Sevier
Smoky Mountains, Southeast Carter, Southeast Greene, Sou...
Instructions: You should monitor later forecasts and be alert for possible Flood
Warnings. Those living in areas prone to flooding should be prepared
to take action should flooding develop.
Turn around, don't drown when encountering flooded roads. Most flood
deaths occur in vehicles.

Affected:
Bristol Weather Conditions icon
Bristol Weather Conditions