Skip to main content

⛈️ Tornado Watch — Ripley WV

major icon Major
Ripley Weather Conditions icon
Ripley Weather Conditions
Investigating icon Investigating

Incident timeline

major icon Major

Investigating - ⚠️ Tornado Watch issued June 18 at 8:56AM EDT until June 18 at 11:00AM EDT by NWS Charleston WV
Severity: Extreme | Urgency: Future
Issued by: NWS Charleston WV
Effective: 2026-06-18T08:56:00-04:00
Expires: 2026-06-18T11:00:00-04:00
TORNADO WATCH 349 REMAINS VALID UNTIL 11 AM EDT THIS MORNING FOR
THE FOLLOWING AREAS
IN KENTUCKY THIS WATCH INCLUDES 2 COUNTIES IN NORTHEAST KENTUCKY BOYD LAWRENCE IN OHIO THIS WATCH INCLUDES 2 COUNTIES IN SOUTHEAST OHIO ATHENS MEIGS IN WEST VIRGINIA THIS WATCH INCLUDES 23 COUNTIES IN CENTRAL WEST VIRGINIA BRAXTON CALHOUN CLAY
GILMER JACKSON NICHOLAS
ROANE WEBSTER
IN NORTHERN WEST V...

Affected:
Ripley Weather Conditions icon
Ripley Weather Conditions