Skip to main content

⛈️ Severe Thunderstorm Watch — Ripley WV

minor icon Minor
Ripley Weather Conditions icon
Ripley Weather Conditions
Investigating icon Investigating

Incident timeline

minor icon Minor

Investigating - ⚠️ Severe Thunderstorm Watch issued June 14 at 4:31PM EDT until June 14 at 9:00PM EDT by NWS Charleston WV
Severity: Severe | Urgency: Future
Issued by: NWS Charleston WV
Effective: 2026-06-14T16:31:00-04:00
Expires: 2026-06-14T21:00:00-04:00
SEVERE THUNDERSTORM WATCH 333 REMAINS VALID UNTIL 9 PM EDT THIS
EVENING FOR THE FOLLOWING AREAS
IN OHIO THIS WATCH INCLUDES 8 COUNTIES IN SOUTHEAST OHIO ATHENS GALLIA JACKSON
MEIGS MORGAN PERRY
VINTON WASHINGTON
IN WEST VIRGINIA THIS WATCH INCLUDES 17 COUNTIES IN CENTRAL WEST VIRGINIA CALHOUN GILMER JACKSON
ROANE TAYLOR
IN NORTHERN WEST VIRGINIA BARBOUR D...

Affected:
Ripley Weather Conditions icon
Ripley Weather Conditions