Skip to main content

🚨 Flash Flood Warning — Ripley WV

major icon Major
Ripley Weather Conditions icon
Ripley Weather Conditions
Investigating icon Investigating

Incident timeline

major icon Major

Investigating - ⚠️ Flash Flood Warning issued May 27 at 7:25AM EDT until May 27 at 10:30AM EDT by NWS Charleston WV
Severity: Severe | Urgency: Immediate
Issued by: NWS Charleston WV
Effective: 2026-05-27T07:25:00-04:00
Expires: 2026-05-27T10:30:00-04:00
FFWRLX The National Weather Service in Charleston has issued a * Flash Flood Warning for...
Northwestern Roane County in central West Virginia...
East Central Jackson County in northwestern West Virginia...
* Until 1030 AM EDT. * At 725 AM EDT, Doppler radar indicated thunderstorms producing
heavy rain across the warned area. Flash flooding is ongoing or
expected to begin shortly.
HAZARD...Flash flooding caused by thunderstorms. SOURCE...Radar indicated. IMPACT...Flash flooding of small c... Instructions: Turn around, don't drown when encountering flooded roads. Most flood
deaths occur in vehicles.
Report flooding to the National Weather Service by calling toll free,
800 401 9535, when you can do so safely.

Affected:
Ripley Weather Conditions icon
Ripley Weather Conditions