Skip to main content

🚨 Tornado Warning — South Charleston WV

major icon Major
South Charleston Weather Conditions icon
South Charleston Weather Conditions
Investigating icon Investigating

Incident timeline

major icon Major

Investigating - ⚠️ Tornado Warning issued June 18 at 7:17AM EDT until June 18 at 7:45AM EDT by NWS Charleston WV
Severity: Extreme | Urgency: Immediate
Issued by: NWS Charleston WV
Effective: 2026-06-18T07:17:00-04:00
Expires: 2026-06-18T07:45:00-04:00
TORRLX The National Weather Service in Charleston West Virginia has issued a * Tornado Warning for...
South central Kanawha County in central West Virginia...
Northwestern Raleigh County in southeastern West Virginia...
North central Wyoming County in southern West Virginia...
Northeastern Logan County in southern West Virginia...
Southwestern Fayette County in southeastern West Virginia...
Southeastern Boone County in central West Virginia...
* Until 745 AM EDT. * At 716 AM EDT, a severe th... Instructions: TAKE COVER NOW! Move to a basement or an interior room on the lowest
floor of a sturdy building. Avoid windows. If you are outdoors, in a
mobile home, or in a vehicle, move to the closest substantial shelter
and protect yourself from flying debris.

Affected:
South Charleston Weather Conditions icon
South Charleston Weather Conditions