Skip to main content

🚨 Severe Thunderstorm Warning — South Charleston WV

major icon Major
South Charleston Weather Conditions icon
South Charleston Weather Conditions
Investigating icon Investigating

Incident timeline

major icon Major

Investigating - ⚠️ Severe Thunderstorm Warning issued June 12 at 2:28PM EDT until June 12 at 3:15PM EDT by NWS Charleston WV
Severity: Severe | Urgency: Immediate
Issued by: NWS Charleston WV
Effective: 2026-06-12T14:28:00-04:00
Expires: 2026-06-12T15:15:00-04:00
SVRRLX The National Weather Service in Charleston West Virginia has issued a * Severe Thunderstorm Warning for...
Central Kanawha County in central West Virginia...
East central Lincoln County in central West Virginia...
Southwestern Clay County in north central West Virginia...
Northwestern Fayette County in southeastern West Virginia...
Northeastern Boone County in central West Virginia...
* Until 315 PM EDT. * At 228 PM EDT, a severe thunderstorm was located 8 miles southwest
of Marmet, o...
Instructions: For your protection move to an interior room on the lowest floor of a
building.

Affected:
South Charleston Weather Conditions icon
South Charleston Weather Conditions