Skip to main content

⛈️ Flood Watch — Ripley WV

minor icon Minor
Ripley Weather Conditions icon
Ripley Weather Conditions
Investigating icon Investigating

Incident timeline

minor icon Minor

Investigating - ⚠️ Flood Watch issued May 27 at 2:20AM EDT until May 28 at 2:00AM EDT by NWS Charleston WV
Severity: Severe | Urgency: Future
Issued by: NWS Charleston WV
Effective: 2026-05-27T02:20:00-04:00
Expires: 2026-05-27T10:30:00-04:00
* WHAT...Flash flooding caused by excessive rainfall continues to be
possible.
* WHERE...Portions of northeast Kentucky, including the following
counties, Boyd, Carter and Greenup, southeast Ohio, including the
following counties, Athens, Gallia, Jackson OH, Lawrence OH, Meigs,
Morgan, Perry, Vinton and Washington, and West Virginia, including
the following counties, Barbour, Braxton, Cabell, Calhoun, Clay,
Doddridge, Gilmer, Harrison, Jackson WV, Kanawha, Lewis, Mason,
Northwest Randolph, Nort...
Instructions: Additional information can be found at https://www.weather.gov/rlx as
well as on our X and Facebook pages.

Affected:
Ripley Weather Conditions icon
Ripley Weather Conditions