Assurant F&I Contracts

Incident Report for System Status

Resolved

Per our Assurant rep, all systems have returned to normal operation.
Posted Jul 11, 2025 - 11:01 EDT

Identified

Assurant is currently experiencing issues rating products both in Tekion and when using the Assurant portal directly. Our Assurant rep has also confirmed this. We do not have an estimated time when the services will be restored.
Posted Jul 11, 2025 - 10:44 EDT
This incident affected: IT/Network Infrastructure.