Skip to main content

⛈️ Severe Thunderstorm Watch — Huntington WV

minor icon Minor
Huntington Weather Conditions icon
Huntington Weather Conditions
Investigating icon Investigating

Incident timeline

minor icon Minor

Investigating - ⚠️ Severe Thunderstorm Watch issued May 27 at 1:11PM EDT until May 27 at 9:00PM EDT by NWS Charleston WV
Severity: Severe | Urgency: Future
Issued by: NWS Charleston WV
Effective: 2026-05-27T13:11:00-04:00
Expires: 2026-05-27T21:00:00-04:00
THE NATIONAL WEATHER SERVICE HAS ISSUED SEVERE THUNDERSTORM WATCH
247 IN EFFECT UNTIL 9 PM EDT THIS EVENING FOR THE FOLLOWING AREAS
IN OHIO THIS WATCH INCLUDES 8 COUNTIES IN SOUTHEAST OHIO ATHENS GALLIA JACKSON
LAWRENCE MEIGS MORGAN
VINTON WASHINGTON
IN WEST VIRGINIA THIS WATCH INCLUDES 34 COUNTIES IN CENTRAL WEST VIRGINIA BRAXTON CALHOUN CLAY
GILMER JACKSON NI...

Affected:
Huntington Weather Conditions icon
Huntington Weather Conditions