Skip to main content

🚨 Severe Thunderstorm Warning — Huntington WV

major icon Major
Huntington Weather Conditions icon
Huntington Weather Conditions
Investigating icon Investigating

Incident timeline

major icon Major

Investigating - ⚠️ Severe Thunderstorm Warning issued June 18 at 6:13AM EDT until June 18 at 6:30AM EDT by NWS Charleston WV
Severity: Severe | Urgency: Immediate
Issued by: NWS Charleston WV
Effective: 2026-06-18T06:13:00-04:00
Expires: 2026-06-18T06:30:00-04:00
At 613 AM EDT, severe thunderstorms were located along a line
extending from 7 miles southwest of Gallipolis to 6 miles south of
Barboursville to near Blaine, moving east at 70 mph.
HAZARD...60 mph wind gusts and penny size hail. SOURCE...Radar indicated. IMPACT...Expect damage to roofs, siding, and trees. Locations impacted include...
Huntington, Ashland, Point Pleasant, Gallipolis, Louisa, Coal Grove,
Wayne, Hamlin, Chesapeake, Proctorville, Blaine, Beech Fork State
Park, Lake Vesuvius, Ya...
Instructions: A Tornado Watch remains in effect until 1100 AM EDT for northeastern
Kentucky...southeastern Ohio...and central, western and northwestern
West Virginia.
Remain alert for a possible tornado! Tornadoes can develop quickly
from severe thunderstorms. If you spot a tornado go at once into the
basement o...

Affected:
Huntington Weather Conditions icon
Huntington Weather Conditions