Skip to main content

🚨 Flash Flood Warning — Ripley WV

major icon Major
Ripley Weather Conditions icon
Ripley Weather Conditions
Investigating icon Investigating

Incident timeline

major icon Major

Investigating - ⚠️ Flash Flood Warning issued May 27 at 10:22AM EDT until May 27 at 10:30AM EDT by NWS Charleston WV
Severity: Severe | Urgency: Immediate
Issued by: NWS Charleston WV
Effective: 2026-05-27T10:22:00-04:00
Expires: 2026-05-27T10:32:00-04:00
The heavy rain has ended. Flooding is no longer expected to pose a
threat. Please continue to heed remaining road closures.
A Flood Watch remains in effect until 200 AM EDT Thursday for
portions of northeast Kentucky, southeast Ohio, and West Virginia.

Affected:
Ripley Weather Conditions icon
Ripley Weather Conditions